bakersnarkMDW
A distillation of the discussion on Discord for easier reference in future (if desired)

A0AABDD2-C4EB-47D8-AF30-DBF4D0F797A8.jpeg 

4/3/20
DragonStorm: @Mar raspberry pi lives!! It's now running the 1541 rom, need to get the hat for it now and then we are in business ! Thanks again man

Evn: @DragonStorm if u find a source of the cables for the pi hat lemme know

Mar: @DragonStorm good to hear, I'm glad it didn't go to waste. I'm also glad it survived a years worth of dust

DragonStorm: Yeah will do, I have one for my real 1541, but I want to get a hat that has 2 serial ports, I want to experiment with copying from pi to a real disk , because why not lol but will keep looking around
Dust still on board I haven't cleaned it yet

Mar: Hah
I was worried it'd be stuck on permanently

DragonStorm: Nothing a bit of 99% IPA can't fix!....mmmm IPA
[tenor] 

BakersnarkMDW: Donated to @evn’s cellar last night from my private reserve.
[image0] 

DragonStorm: Limited release
Tho the colour looks more like a lager
Lol

Evn:
[IMG_20200304_094659] 

BakersnarkMDW: All colour provided by the wooden table.
None drunk by children so far?

Evn: So far...

DragonStorm: Yep mislabeled that's a bottle of corona aka cat piss
The high acidic levels in that shot will clean anything, but damn the smell it leaves behind is just foul lol

BakersnarkMDW: I think with that 1541 Pi hat you use a standard C64 cable. When I first read the instructions it was a bit confusing with all the talk about “cables”, but on a recent reread it seems the Hat IS the part of the cable which is different to a standard C64 cable which is why your hat @evn has the DIN connector allowing an unadulterated cable to plug in. The Pi does all the work and simply needs 4 lines from the C64 serial port to pass through a logic level converter to 4pins on the Pi GPIO to change the voltage level from 5v (C64) to 3.3v (Pi) and back. There is a link to the simplest cable required which is just wiring through a logic level converter.
(Just to clear up confusion possibly only I was having, the following picture is his demonstration of how to attach the wires without soldering and shows a 2 channel rather than the 4 channel logic level converter, so only has 4 pads each side rather than 6. He didn’t have a spare 4 channel not already wired up)
[image0] 

Your Hat @evn has the converter, as indicated, wired between the DIN6 and the GPIO connector. The rest is quality of life with the speaker for drive noises, LED to show drive activity, and the display & buttons to allow Pi control without keyboard and monitor.
[image0] 

Evn: so you're saying mine is a cool one

BakersnarkMDW: Guess so. I just need to see if I can get it to work with a Pi 1 or 2 when it’s requirement is a 3 (which I don’t have) - there are suggestions software overclocking should work. Pi 4 is a no go as they made significant changes on the 4 (which I also don’t have anyway).
Here is the wiring diagram for the simplest “hatless” cabling option:
[mypi1541_v1-0]

Evn: we can hunt for a pi3
I'll have a poke around

DragonStorm: Where U get your pi1541 hat from?

Evn: ...
@DragonStorm theres a dude on the facebook aussie commodore group who sells them
thats where that one came from

DragonStorm: Damn FB strikes again!
[tenor] 
How much the guy selling them for?
Gamesmen are a rip off they want $85

Evn: @DragonStorm bought it a long time ago so cant remember

DragonStorm: Have you ever bought from Melbourne consolerepros.com before?

Evn: > Have you ever bought from Melbourne consolerepros.com before?
@DragonStorm not me

DragonStorm: Seems to be the chaepest pre built hats that can find with 2 serial ports

BakersnarkMDW: @DragonStorm do you need a 2 serial Hat? Just put the Pi at the end of the chain.

DragonStorm: @bakersnarkMDW totally didn't think about doing that

BakersnarkMDW: Something’s got to be on the end! Don’t think there’s an issue with doing it that way.
See how we go with @evn’s hat, but I might look at hand drawing an equivalent board and building it.

My hand drawn but functional magnet driver board for Getaway pinball Supercharger loop. Double-sided board and I had to work out the traces from a populated board.
[image0]
[image1] 
(Zoom in on the bottom of the unpopulated board [top].)

Evn: I gotta teach you KiCAD man

BakersnarkMDW: Where’s the craft?

Evn: Save you from sulphuric acid

BakersnarkMDW: Sulphuric acid is the least of my worries. 😁

6/3/20
DragonStorm: @bakersnarkMDW regarding the pi1541 chain, was reading and there are 2 options A and B, option B uses the 7406 chip and can be used in a chain where as option A shouldn't be used in a chain

BakersnarkMDW: @DragonStorm Yeah, I thought of that after I suggested adding to the chain. It’s the problem with a project like this, I haven’t seen any documentation specifically for the Pi hat I’ve borrowed from @evn, just read the primary document page ( https://cbm-pi1541.firebaseapp.com ) and the link it has to the simplest version of the “cable”. Any hat is someone else’s implementation of the designers instructions. I was assuming that anyone going to the trouble of making a complete Pi hat would make the more versatile B option, but the board I have seems to be option A. The only difference is the addition of the 7406 to B ($3 from Jaycar) so I don’t know why it’s omitted. The distinction between option A & B was made more confusing by them both sharing optional parts - speaker, buttons, activity LED & the original description doesn’t mention the display which is on Evan’s hat.

DragonStorm: Yeah they all have the display OLED 0.96" on them now
Yeah def going option B just so I can copy stuff to a real disk because why not lol

7/3/20
DragonStorm: Ok I give up, does anyone have a pi1541 for the c64? If so how do you get it to load games, mine can see the games but when ever I try to load a game it just freezes on the load "*",8 command

BakersnarkMDW: Are you seeing the games or the disk image files (I’m just speculating here because I haven’t tried operating one yet).
And assuming you’ve got an option B hat you’ve done this:
“If you build option B you will need to place the line "splitIECLines = 1" in the options.txt file found in the root folder of the SD card”

DragonStorm: Yeah I'm commented that line, I can see the files by typing LIST , I can also load the FB64 file browser but when I try to load a game it just hangs
* uncommented

Mar: Do you have to specify ,8,1

DragonStorm: So here are the exact commands I have tried..
Load "$",8 <--- this works
LIST <---- this works
Mount image on pi and then type LOAD "*",8 results in hanging not progressing even leaving it for 10 mins

BakersnarkMDW: Are you using the Pi with keyboard and monitor? That might be the clearest method to start with.

DragonStorm: LOAD "FB64" ,8
RUN
This loads the file browser
No it has an lcd screen on it and menu buttons

BakersnarkMDW: You might want to try get it going with monitor and keyboard on Pi first and work backwards.
How many amps is your Pi power supply?

DragonStorm: It's 2a old Samsung phone charger
Was all I had (use it for my NES mini)

BakersnarkMDW: “Please ensure that you use an adequate power supply for the Pi. The Respberry Pi Foundation recomend a 2.5A minimum.
So far, 100% of problems encountered by others in setting up and getting PI1541 working were down to them using an incorrect power supply or attempting to power all kinds of exotic devices through the Pi's USB ports whilst trying to use it.”

DragonStorm: I'll try get a 2.4amp however I did google that and everything I found seemed to suggest that 2 amp would be enough
I do have a 3amp charger for my current phone
I could try that

BakersnarkMDW: 2.5 does seem a lot for a USB plugpack.
I got piles of them but I don’t think many of them are much over 1A.

Mar: Have you tried specifying the file name of what you want to load?
I note that “FB64” worked

DragonStorm: Yeah I had super Mario Bros on there as a test and same thing when I tried to load "SMB.d64",8 as well as tried load "SMB" ,8 had no luck

Mar: ,8,1
Tried that?

DragonStorm: No didn't add the track

BakersnarkMDW: You are trying to load the disk image.

Mar: Oh yeah
D64 is a disk image
You want to be loading the file on the disk

BakersnarkMDW: You need to mount SMB.d64 then run the Mario Bros file on that.

DragonStorm: That's the problem
Once the image is mounted I can not load
That's where it just sits there and does not find anything, it stays on SEARCHING

Mar: So you mount an image first right?

BakersnarkMDW: See FB64 is a C64 file straight on the SD. Everything else is in images.

Mar: Once you mount a disk image, you should then be able to list the files on the disk

DragonStorm: Yeah all the videos show that working but it's no go for me
If I don't mount the image I can load and list
But if I mount the image it won't load

BakersnarkMDW: I say go to keyboard and monitor on Pi because it’s likely much easier to know when an image has been mounted. Get it working like that then work back.
Are you mounting using the Pi buttons or FB64?

DragonStorm: Tried both ways

Mar: I don’t know enough about the tech to really provide any input. I’m assuming this is a Pi emulating a 1541? Plugged somehow into a real C64

DragonStorm: Yeah plugged in via the serial cable

Mar: That’s hardcore
Might be power like @bakersnarkMDW said

DragonStorm: Yeah I wanted to go all out and chose option B version so I could copy games to a real disk and play them on my real 1541
I'll try all those suggestions tomorrow and let you know how I go
So frustrating, I just want to sit there and listen to that sweet sweet Sid chip filling the air with awesomeness

bennbanasik: I dont have the pi option but do have the sd2eic. Had the same problem, found 2 things that fixed it. Formatting couldn't be ntfs, and too many files in a folder made it hang.
Might not be relevant but wouldnt hurt to strip it back to a single image you know works and then try it

DragonStorm: Yeah prob has been there since the start when I only had SMB on there, so I put some other games on there thinking the game might be bad but same result with all games, there is only 3 games on there

bennbanasik: Hmm thats really odd. My sd2eic is very finicky too, some disk images just dont work. Meanwhile stock Amiga 500 loves the world and runs everything I throw at it. Shame theres no affordable perfect solution for c64

Mar: Can you list the files on the disk?

DragonStorm Yes lol that's the weird part, it lists the files and I can see all the games (3) I have on it but it just won't progress past that I'll be trying my 3amp phone charging cable today to see if it's a power issue

Evn: Isn't the pihat a perfect solution?
thought it emulated a 1541 perfectly
I'm a big fan of my ezflash for the c64
has made things like Zack Mackracken way more fun to play

bennbanasik: sd2eic is faster and apparently the 1541 is slower than original, I watched a bunch of reviews and comparisons when I decided on the sd2eic, however with the way it does the connection it can fail, a soldiered internal solution would be awesome but then I'd probably just go for that new c64 thing mar has

BakersnarkMDW: The Pi1541 is full chip emulation whereas the SD2EIC isn’t - it has problems with fastloaders not in its emulation and copy protected disks. Pi1541 should work with pretty much everything.


Evn: I've got an sd2iec too, my understanding is that it's not 100% whereas the pi1541 is supposedly "cycle accurate"

BakersnarkMDW: If you get your image mounting sequence right, you can use fastload cartridge with Pi and up speed. Sd2IEC has some fastloaders built in but carks it on other fast loaders with the games and carts.

Evn: I've got an epyx fastloader too interesting....

BakersnarkMDW: Watch video, he compares and explains some of it.

bennbanasik:


BakersnarkMDW: Pi starts in an emulation mode similar to SD2EIC so it works with the C64 File Browser (fb64) but will then drop into full cycle accurate emulation making it much more compatible including all fast loaders.

bennbanasik: This dude compares too, both load but there are some speed differences with the pi1541

BakersnarkMDW: Does he use a fastload cart?
The SD2EIC has some fastloaders built in making it natively faster with “regular” files but incompatible with stuff that has its own fastload that it doesn’t know. Once in full emulation mode the Pi uses anything a 1541 can.

Evn: Yeah I don't care about better quality of life, I care that it acts exactly like a 1541
For sure the sd2iec trades some compatability for quality of life
Is the TLDR, that the pi and a fastload cart is exactly like a real 1541 and a fastload cart?
Because that's what I'm aiming for

bennbanasik: Nah its not, has problems because the cycle rate isnt perfect, so its better to go without a fastload cart if youre doing the pi1541
However, in saying all this, most games are going to work with both solutions... just need hunting for different images if they dont load
Or, buy new awesome games like Hessian

BakersnarkMDW: Pi has just got to be in full emulation mode after the image is mounted for fastload cart to work. It’s in the video, nothing tricky, I think you just have to mount using the Pi buttons/keyboard rather than fb64 because the Pi uses SD2EIC compatibility to work with fb64 with built in fastloaders that trip up on the cartridge fastloader.
@DragonStorm have you tried mounting the image at the Pi end using the buttons and screen (or keyboard/monitor) without loading fb64 at all? Is your C64 stock or are you using a fastload cart/kernal?

Mar: @DragonStorm you mention you can see the files. That's not what I mean. It sounds like you can see the disk images (.D64). But can you see the files within the disk images? Can you list those on the C64?
🍌
Once you've mounted the disk image, do this on the C64 and the contents of the disk should look similar to this
[Commodore64_directory_listing_16] 
I'm assuming you know all that. But just wanted to double check
In this example. Loading the game on this disk would be either
LOAD "*",8,1
or
LOAD "LOADER 3D REV.",8
The title of the disk image at 0 is just the title. Not the program
PRG is the program on the disk

BakersnarkMDW: I haven’t done any of this, just going by videos (😁) - this guy shows how he uses his SD2EIC but it is a good visual (apart from rolling black bars) on using fb64. He both mounts the image and loads the game from within File Browser. Skip to 7m15s to see him grab an image, pop it on the SD card and load from fb64. Might be good to use same game from same source.


DragonStorm: @bakersnarkMDW yes OG c64 no fast loader
@Mar that's correct I can see the images "d64", but I can not load the image and list the files inside the image

BakersnarkMDW: Have a look at the video (it’s not Pi but is fb64) and follow his steps from 7min with the same image.

DragonStorm: Thanks will have a chance to try again after lunch

BakersnarkMDW: You’ll like this guy doing all his downloading and card loading on his Amiga. 🙂

DragonStorm: It looks like it's working
Does ghouls n ghosts have different music on c64

Evn: Yes

BakersnarkMDW: Pi1541 @DragonStorm?

DragonStorm: Yes got it working!!!

BakersnarkMDW: Do we know the issue?

DragonStorm: Music on ghouls n ghosts is weird
Only thing I changed was the power supply

Mar: Music on Ghouls C64 is incredible
About the only good thing about it
BAM

DragonStorm: [IMG_20200307_141922]   

Mar: Awesome stuff. Love a breadbin

BakersnarkMDW: I think Pi power is really important because the Pi’s GPIO is providing all the power for the logic level converter.
The 7406 on your luxury hat probably sinks a bit more power too. 🎩

DragonStorm: Thanks for the help man
Now need to hook up to the stereo and enjoy the Sid!!
Random item from my Tabletop Games Collection
[image] 
See it & the rest here:
Quote 0 0